Verbindungsprobleme eines HD2 (WP7) mit Win 7 (Zune)

2011/02/12

Der Idealfall sieht wie folgt aus. Man nehme sein mobiles Endgerät verbinde es mit dem PC (vorzugsweise per USB), und Betriebssysteme aktuellen Standes erkennen per PnP die Verbindung und starten eine entsprechende Kommunikations- Software. Jeder der sich unter Windows mit dieser Materie beschäftigt hat, dem sagt ActiveSync 4.5, Windows Mobile 6.5 und „schnelle Synchronisation“ bestimmt etwas.

Versucht man das aber unter Win 7 64bit, dem Nachfolger von ActiveSync dem Windows Mobile Center und der Erkennung unter Zune, dann könnte das nicht allzu glatt gehen, wie man sich das im Marketing so manchmal ausmalt. Lange Rede – kurzer Sinn, nach einem Vorspiel mit Zune wollte Windows das LEO nicht erkennen. Die Funktionalität des USB Kabel wurde unter Win XP geprüft, schließlich ließ sich ja das HTC normal aufladen.

Windows wollte das mit Windows Phone 7 getriebene Gerät einfach nicht im Gerätemanager richtig einbinden. Somit auch keine Möglichkeit einer Software darauf zuzugreifen. Der Versuch den Treiber („Program Files/Zune/Drivers/“) manuell über „Treiber aktualisieren…“ neu zu installieren blieb genauso ohne Erfolg, wie der Versuch durch eine Software namens „Zune Devices“ als fehlend diagnostizierte Dateien aus dem kompletten Zune Package manuell nachzukopieren.

Ein Reise durch die Foren dieser Welt brachte mich mit Umwegen auf den richtigen Pfad. Unter dem Reiter „Logs“ von Zune Devices fand ich unter dem Suchbegriff „failed“ den Hinweis „Device not started: Device has problem: 0x1f: CM_PROB_FAILED_ADD“. Ein Stück weiter unten dann noch „Queueing up error report since device has a PnP problem…“.

Jetzt muss mann dazu noch wissen bzw. in einem anderen Rechner gesehen haben (natürlich ohne Verbindungsprobleme), dass Zune ähnlich dem Windows Mobile Center einen kleinen Dienst startet; „wmdc.exe“ respektive „WMZuneComm.exe“. Und jetzt raten wir alle mal mit welchem Benutzer bzw. Benutzerberechtigungen zumindest der Dienst von Zune aufgerufen wurde ?!? Richtig der „Lokale Dienst“. Ein, zwei… schnell gekuckt, und siehe da, besagter Benutzer hatte keine Rechte. Ob das mit Ansicht zu tun hat lokal als Admin zu arbeiten, oder dem Überleben eines schweren BSOD in den Kindheitstagen des Betriebssytems, sei hier mal dahin gestellt. Die Lösung lautet jedenfalls wie folgt:

1. Rechtsklick auf Computer

2. Klick Verwalten (ggf. administrativen Zugriff gestatten)

3. Klick „Lokale Benutzer und Gruppen“

4. Doppelklick auf Gruppen

5. Doppelklick auf „Administratoren“

6. Klick auf „Hinzufügen…“ & Klick auf „Erweitert…“ & Klick auf „Jetzt suchen“

7. Doppelklick „LOKALER DIENST“

8. Klick auf „Ok“